Application Server Solutions for Microsoft IIS and ASP.NET
       solutions   products   partners   company   support   downloads         store
JTurbo Self-Help: FAQ
Back to Search >  Back to Search Results

Faq ID 232
Product BlueDragon
Category Installation, Known Limitations and Workarounds, Web Application
Question What do I need to add to run BlueDragon/J2EE on Websphere 4?
Answer In order to deploy the BlueDragon 6.1 webapp on WebSphere 4.0 you must make two changes (which are not required on WebSphere 5):

  1. In the "WEB-INF/web.xml" file, change the DOCTYPE declaration from this:

    <!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN" "http://java.sun.com/dtd/web-app_2_3.dtd">

    to this:

    <!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.2//EN" "http://java.sun.com/j2ee/dtds/web-app_2_2.dtd">

    This change must be made because WebSphere 4.0 implements the Servlet API 2.2, while all other major J2EE servers (including WebSphere 5.1) implement the newer Servlet API 2.3.

  2. Copy the "crimson.jar" and "jaxp.jar" files from the "WEB-INF/opt" directory to the "WEB-INF/lib" directory. See the README within the "WEB-INF/opt" direcotory for more information.



   
company media information terms of use privacy policy contact us