Application Server Solutions for Microsoft IIS and ASP.NET
       solutions   products   partners   company   support   downloads         store
View Interest List Message Details
<< Back to Search Results

Date: 08/09/2007
From: matt@newatlanta.com
Subject: Re: [ServletExec] Debugging AS with Eclipse
Danny,
That's exactly what you need to do.

For an ASI running behind IIS the main class would need to be 
"ServletExec" (not                                                    
"com.newatlanta.servletexec.ServletExecServer").

The ServletExecServer one is for an SE AS instance that runs behind the 
built-in webserver (which is not what you have installed at the moment).
But with SE 5.x you can't merely change that classname and have it work 
that way... you'd have to run the installer to install such an instance, 
and then configure a different Launch configuration in Eclipse... one 
which uses com.newatlanta.servletexec.ServletExecServer as the main 
class and whose arguments point to the correct home folder for that 
instance type.

Matt McGinty
Software Engineer
New Atlanta Communications, LLC
http://www.newatlanta.com 



Lin, Danny wrote:
>
> Hi Matt,
>
>  
>
> Let me try your note here. Actually I just got it working but somewhat 
> different than your description here. I am calling the ServletExec 
> class instead of ServletExecServer. What's the difference between 
> these two classes?
>
>  
>
> Thanks.
>
>  
>
>  
>
> ------------------------------------------------------------------------
>
> *From:* servletexec-interest-owner@newatlanta.com 
> [mailto:servletexec-interest-owner@newatlanta.com] *On Behalf Of 
> *matt@newatlanta.com
> *Sent:* Thursday, August 09, 2007 2:11 PM
> *To:* servletexec-interest@newatlanta.com
> *Subject:* Re: [ServletExec] Debugging AS with Eclipse
>
>  
>
> Danny,
>
> Don't uninstall the IIS Adapter.
>
> I recommend that you that read the Eclipse Documentation (or do some 
> googling) to learn how to run a simple HelloWorld java application 
> inside Eclipse's debugger and step-debug it. You need to be able to   
do 
> that and understand it before you try doing it with something more 
> complex like an Application Server (such as SE).
>
> Then use what you learn from that effort, together with the contents 
> of StartServletExec.bat to launch SE AS within Eclipse (just as you 
> did the HelloWorld java application).
>
> I can't help you much with doing "remote java application        
debugging".
> But running SE inside Eclipse is fairly straightforward.
>
> I'm no Eclipse guru, but I have done this and it works.
> Here are some guidelines to help you out.
>
> In Eclipse, switch to the Java Perspective.
> Then go  - Run - Debug...
> to bring up the "create, manage, and run configurations" dialog  
as 
> show below:
>
>
>
> click the icon in the upper left to add a new Launch configuration.
> Look in the StartServletExec.bat file to see what the "Main           
class:" 
> should be.
> For an ASI running behind IIS it the main class would need to be 
> "ServletExec" (not                                               
"com.newatlanta.servletexec.ServletExecServer").
>
> Then access the other tabs such as the "Arguments" tab (to       
specify the 
> java arguments and the program arguments), and the "Classpath"   
tab (to 
> add the JARs that SE needs).
> Just mimick what StartServletExec.bat does.
>
> If you set those things up correctly then you should then be able to 
> select that new configuration and hit the "Debug" button to      
start it 
> running inside Eclipse's debugger.
> At that point you can set breakpoints in your Servlet and then send a 
> request to your Servlet so that you can step-debug it.
>
> If that's not enough to get you going then you may need to contact 
> Eclipse Technical Support and ask them how to mimick (within Eclipse) 
> what the StartServletExec.bat batch file does.
>
>
>
> Matt McGinty
> Software Engineer
> New Atlanta Communications, LLC
> http://www.newatlanta.com 
>
>
>
> Lin, Danny wrote:
>
> Matt,
>
>  
>
> Do you know the exact steps "to run SE AS Instance inside             
Eclipse"? In 
> Eclipse, I have a project setup where I put my web-app code (Java code 
> as well as other assets). Do I need to create a project and point it 
> to SE so that I can "debug" SE?
>
>  
>
> You also mentioned about running behind its build-in webserver. If I 
> uninstall IIS adapter and install its build-in webserver, will I be 
> able to do Remote Java Application debug? Or I still need to launch SE 
> AS within Eclipse?
>
>  
>
> Thanks.
>
> Danny
>
>  
>
>  
>
> ------------------------------------------------------------------------
>
> *From:* servletexec-interest-owner@newatlanta.com 
> <mailto:servletexec-interest-owner@newatlanta.com> 
> [mailto:servletexec-interest-owner@newatlanta.com] *On Behalf Of 
> *matt@newatlanta.com <mailto:matt@newatlanta.com>
> *Sent:* Thursday, August 09, 2007 12:21 PM
> *To:* servletexec-interest@newatlanta.com 
> <mailto:servletexec-interest@newatlanta.com>
> *Subject:* Re: [ServletExec] Debugging AS with Eclipse
>
>  
>
> Danny the correct way to step-debug your Servlets that run inside SE, 
> using Eclipse IDE is to run your SE AS Instance inside Eclipse.
> For that you need to study the StartServletExec.bat file that's used 

> to startup your instance.
> Use what you see there to configure Eclipse to start the instance.
>
> This is typically done when the instance is running behind it's 
> built-in webserver (not behind IIS).
> But I see no reason why you could not have the instance running behind 
> IIS.
> The only difference is that you'd be having Eclipse start the         
instance 
> rather than using the batch file or the Windows Service mechanism to 
> start it.
>
> This FAQ may help:
>                                                                            
http://www.newatlanta.com/c/support/servletexec/self_help/faq/detail?faqId=2
>
> Consider a simple HelloWorld java application.
> If you can set that up in Eclipse and step debug it, then you'd just 

> need to do something similar to that to have Eclipse run your SE AS 
> instance in its debugger. Then you can set breakpoints in your Servlet 
> code, make a request, and step debug your code.
>
>
> Matt McGinty
> Software Engineer
> New Atlanta Communications, LLC
> http://www.newatlanta.com 
>
>
>
> Lin, Danny wrote:
>
> I have two AS instances installed. The URLs are cm.localhost and 
> em.localhost. I am able to launch the application (i.e. IIS and 
> ServletExec configured correctly.) I want to be able to run 
> step-through debugger from Eclipse. I created a project and set it up 
> for remote Java Application. I entered the following connection 
> properties: host: cm.localhost, port: 8888. The port 8888 is the port 
> when cm instance was installed. Is this a correct way to make debug 
> connection? Or, is there another port that I should use? After I click 
> "Debug" I am getting a Timeout exception.
>
>  
>
> Please help.
>
>  
>
> Thanks.
>
> Danny
>
>  
>

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<html>
<head>
 <meta content="text/html;charset=ISO-8859-1"                      
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
<font face="Verdana">Danny,<br>
That's exactly what you need to do.<br>
<br>
</font>For an ASI running behind IIS the main class would need to be
"ServletExec" (not
"com.newatlanta.servletexec.ServletExecServer").<br>
<br>
The ServletExecServer one is for an SE AS instance that runs behind the
built-in webserver (which is not what you have installed at the                 
moment).<br>
But with SE 5.x you can't merely change that classname and have it work
that way... you'd have to run the installer to install such an
instance, and then configure a different Launch configuration in
Eclipse... one which uses com.newatlanta.servletexec.ServletExecServer
as the main class and whose arguments point to the correct home folder
for that instance type.<br>
<br>
<pre class="moz-signature" cols="72">Matt McGinty
Software Engineer
New Atlanta Communications, LLC
<a class="moz-txt-link-freetext"                                   
href="http://www.newatlanta.com">http://www.newatlanta.com</a>
; </pre>
<br>
<br>
Lin, Danny wrote:
<blockquote
cite="mid92D6B7F3215ED9468775D945DBBED20804A91FF9@ASHEVS005.mcilink.com
4;
type="cite">
 <meta http-equiv="Content-Type" content="text/html;          
">
 <meta name="Generator" content="Microsoft Word 11 (filtered  
medium)">
<!--[if !mso]>
<style>
v\:* {behavior:url(#default#VML);}
o\:* {behavior:url(#default#VML);}
w\:* {behavior:url(#default#VML);}
.shape {behavior:url(#default#VML);}
</style>
<![endif]--><o:SmartTagType
namespaceuri="urn:schemas-microsoft-com:office:smarttags"             
name="State">
 <o:SmartTagType
namespaceuri="urn:schemas-microsoft-com:office:smarttags"             
name="place"><o:SmartTagType
namespaceuri="urn:schemas-microsoft-com:office:smarttags"             
name="City">
 <o:SmartTagType
namespaceuri="urn:schemas-microsoft-com:office:smarttags"
name="PersonName"><!--[if !mso]>
<style>
st1\:*{behavior:url(#default#ieooui) }
</style>
<![endif]-->
 <style>
<!--
/* Font Definitions */
@font-face
{font-family:Tahoma;
panose-1:2 11 6 4 3 5 4 4 2 4;}
@font-face
{font-family:Verdana;
panose-1:2 11 6 4 3 5 4 4 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
{margin:0in;
margin-bottom:.0001pt;
font-size:12.0pt;
font-family:"Times New Roman";
color:black;}
a:link, span.MsoHyperlink
{color:blue;
text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
{color:#606420;
text-decoration:underline;}
pre
{margin:0in;
margin-bottom:.0001pt;
font-size:10.0pt;
font-family:"Courier New";
color:black;}
span.EmailStyle18
{mso-style-type:personal;
font-family:Arial;
color:windowtext;}
span.EmailStyle19
{mso-style-type:personal;
font-family:Arial;
color:navy;}
span.EmailStyle20
{mso-style-type:personal-reply;
font-family:Arial;
color:navy;}
@page Section1
{size:8.5in 11.0in;
margin:1.0in 1.25in 1.0in 1.25in;}
div.Section1
{page:Section1;}
-->
 </style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
 <o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
                                                                                
</o:SmartTagType></o:SmartTagType></o:SmartTagType></o:Smar
tTagType>
 <div class="Section1">
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color: navy;">Hi       
Matt,<o:p></o:p></span></font></p>
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color:                         
navy;"><o:p>&nbsp;</o:p></span></font></p
>
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color: navy;">Let me   
try
your note here. Actually I just
got it working but somewhat different than your description here. I am
calling
the ServletExec class instead of ServletExecServer. What&#8217;s the
difference
between these two                                                               
classes?<o:p></o:p></span></font></p>
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color:                         
navy;"><o:p>&nbsp;</o:p></span></font></p
>
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color:                         
navy;">Thanks.<o:p></o:p></span></font></p>
;
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color:                         
navy;"><o:p>&nbsp;</o:p></span></font></p
>
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color:                         
navy;"><o:p>&nbsp;</o:p></span></font></p
>
 <div>
 <div class="MsoNormal" style="text-align: center;"      
align="center"><font
color="black" face="Times New Roman"                        
size="3"><span
style="font-size: 12pt; color: windowtext;">
 <hr tabindex="-1" align="center" size="2"     
width="100%"></span></font></div>
 <p class="MsoNormal"><b><font color="black" 
face="Tahoma" size="2"><span
style="font-size: 10pt; font-family: Tahoma; color: windowtext;            
font-weight: bold;">From:</span></font></b><font
color="black" face="Tahoma" size="2"><span
 style="font-size: 10pt; font-family: Tahoma; color: windowtext;">

<a class="moz-txt-link-abbreviated"                                
href="mailto:servletexec-interest-o
wner@newatlanta.com">servletexec-interest-o
wner@newatlanta.com</a>
[<a class="moz-txt-link-freetext"                                  
href="mailto:servletexec-interest-o
wner@newatlanta.com">mailto:servletexec-interest-o
wner@newatlanta.com</a>] <b><span
style="font-weight: bold;">On Behalf Of                            
</span></b><a class="moz-txt-link-abbreviated"         
href="mailto:matt@newatlanta.com">matt@newatlanta.com</a><
br>
 <b><span style="font-weight:                                     
bold;">Sent:</span></b> Thursday, August
09, 2007
2:11 PM<br>
 <b><span style="font-weight:                                     
bold;">To:</span></b> <st1:PersonName
w:st="on"><a class="moz-txt-link-abbreviated"         
href="mailto:servletexec-interest@newatlanta.com">servletexec-i
nterest@newatlanta.com</a></st1:PersonName><br>
 <b><span style="font-weight:                                     
bold;">Subject:</span></b> Re:
[ServletExec]
Debugging AS with Eclipse</span></font><font                     
color="black"><span
style="color:                                                              
windowtext;"><o:p></o:p></span></font></p>

 </div>
 <p class="MsoNormal"><font color="black"          
face="Times New Roman"
size="3"><span style="font-size:                           
12pt;"><o:p>&nbsp;</o:p></span></font></p
>
 <p class="MsoNormal"><font color="black"          
face="Verdana" size="3"><span
style="font-size: 12pt; font-family: Verdana;">Danny,<br>
 <br>
Don't uninstall the IIS Adapter.<br>
 <br>
I recommend that you that read the Eclipse Documentation (or do some
googling)
to learn how to run a simple HelloWorld java application inside
Eclipse's
debugger and step-debug it. You need to be able to do that and
understand it
before you try doing it with something more complex like an Application
Server
(such as SE).<br>
 <br>
Then use what you learn from that effort, together with the contents of
StartServletExec.bat to launch <st1:place                                    
w:st="on"><st1:City w:st="on">SE</st1:City>
  <st1:State w:st="on">AS</st1:State></st1:place>   
within Eclipse (just
as you
did the HelloWorld java application).<br>
 <br>
I can't help you much with doing "remote java application             
debugging".<br>
But running SE inside Eclipse is fairly straightforward.<br>
 <br>
I'm no Eclipse guru, but I have done this and it works.<br>
Here are some guidelines to help you out.<br>
 <br>
In Eclipse, switch to the Java Perspective.<br>
Then go&nbsp; - Run - Debug... <br>
to bring up the "create, manage, and run configurations" dialog as
show below:<br>
 <br>
 </span></font><img id="_x0000_i1025"
src="cid:part1.00060300.06030306@newatlanta.com"                      
height="640"
width="899"><br>
 <br>
click the icon in the upper left to add a new Launch configuration.<br>
Look in the StartServletExec.bat file to see what the "Main class:"
should be.<br>
For an ASI running behind IIS it the main class would need to be
"ServletExec" (not
"com.newatlanta.servletexec.ServletExecServer").<br>
 <br>
Then access the other tabs such as the "Arguments" tab (to specify
the java arguments and the program arguments), and the "Classpath"
tab (to add the JARs that SE needs).<br>
Just mimick what StartServletExec.bat does.<br>
 <br>
If you set those things up correctly then you should then be able to
select
that new configuration and hit the "Debug" button to start it running

inside Eclipse's debugger.<br>
At that point you can set breakpoints in your Servlet and then send a
request
to your Servlet so that you can step-debug it.<br>
 <font face="Verdana"><span style="font-family:         
Verdana;"><br>
If that's not enough to get you going then you may need to contact
Eclipse
Technical Support and ask them how to mimick (within Eclipse) what the
StartServletExec.bat batch file does.<br>
 <br>
 <br>
 <br>
 </span></font><o:p></o:p></p>
 <pre><font color="black" face="Courier New"       
size="2"><span
style="font-size: 10pt;">Matt                                      
McGinty<o:p></o:p></span></font></pre>
 <pre><font color="black" face="Courier New"       
size="2"><span
style="font-size: 10pt;">Software                                  
Engineer<o:p></o:p></span></font></pre>
 <pre><font color="black" face="Courier New"       
size="2"><span
style="font-size: 10pt;">New <st1:City                          
w:st="on"><st1:place                                            
w:st="on">Atlanta</st1:place></st1:City>               
Communications,                                                                 
LLC<o:p></o:p></span></font></pre>
 <pre><font color="black" face="Courier New"       
size="2"><span
style="font-size: 10pt;"><a                                     
href="http://www.newatlanta.com">http://www.newatlanta.com</a>
; <o:p></o:p></span></font></pre>
 <p class="MsoNormal"><font color="black"          
face="Times New Roman"
size="3"><span style="font-size: 12pt;"><br>

 <br>
Lin, Danny wrote: <o:p></o:p></span></font></p>
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color:                         
navy;"><u1:SmartTagType
namespaceuri="urn:schemas-microsoft-com:office:smarttags"             
name="State"><u1:SmartTagType
namespaceuri="urn:schemas-microsoft-com:office:smarttags"             
name="place"><u1:SmartTagType
namespaceuri="urn:schemas-microsoft-com:office:smarttags"             
name="City"><u1:SmartTagType
namespaceuri="urn:schemas-microsoft-com:office:smarttags"
name="PersonName"><!--[if gte mso 9]><xml>
    <u1:shapedefaults u2:ext="edit" spidmax="1026"/>
</xml><![endif]--><!--[if gte mso 9]><xml>
    <u1:shapelayout u3:ext="edit">
     <u1:idmap u3:ext="edit" data="1"/>
    </u1:shapelayout>
</xml><![endif]--&
gt;</u1:SmartTagType></u1:SmartTagType></u1:SmartTagType></
u1:SmartTagType>Matt,<u1:p></u1:p></span></font><o
:p></o:p></p>
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color:                         
navy;"><u1:p>&nbsp;</u1:p></span></font><
o:p></o:p></p>
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color: navy;">Do you   
know
the exact steps &#8220;to run
SE AS Instance inside Eclipse&#8221;? In Eclipse, I have a project setup
where
I put my web-app code (Java code as well as other assets). Do I need to
create
a project and point it to SE so that I can &#8220;debug&#8221;          
SE?<u1:p></u1:p></span></font><o:p></o:p><
;/p>
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color:                         
navy;"><u1:p>&nbsp;</u1:p></span></font><
o:p></o:p></p>
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color: navy;">You also

mentioned about running behind
its build-in webserver. If I uninstall IIS adapter and install its
build-in
webserver, will I be able to do Remote Java Application debug? Or I
still need
to launch <st1:place u4:st="on"><st1:City                    
u4:st="on"><st1:place
w:st="on"><st1:City                                             
w:st="on">SE</st1:City></st1:place> <st1:State
u4:st="on"><st1:State                                           
w:st="on">AS</st1:State></st1:State></st1:City>&l
t;/st1:place>
within                                                                          
Eclipse?<u1:p></u1:p></span></font><o:p></o:p&g
t;</p>
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color:                         
navy;"><u1:p>&nbsp;</u1:p></span></font><
o:p></o:p></p>
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color:                         
navy;">Thanks.<u1:p></u1:p></span></font><o:p
></o:p></p>
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color:                         
navy;">Danny<u1:p></u1:p></span></font><o:p&g
t;</o:p></p>
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color:                         
navy;"><u1:p>&nbsp;</u1:p></span></font><
o:p></o:p></p>
 <p class="MsoNormal"><font color="navy"           
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial; color:                         
navy;"><u1:p>&nbsp;</u1:p></span></font><
o:p></o:p></p>
 <div>
 <div class="MsoNormal" style="text-align: center;"      
align="center"><font
color="black" face="Times New Roman"                        
size="3"><span
style="font-size: 12pt; color: windowtext;">
 <hr tabindex="-1" align="center" size="2"     
width="100%"></span></font></div>
 <p class="MsoNormal"><b><font color="black" 
face="Tahoma" size="2"><span
style="font-size: 10pt; font-family: Tahoma; color: windowtext;            
font-weight: bold;">From:</span></font></b><font
color="black" face="Tahoma" size="2"><span
 style="font-size: 10pt; font-family: Tahoma; color: windowtext;"> 
<a
href="mailto:servletexec-interest-o
wner@newatlanta.com">servletexec-interest-o
wner@newatlanta.com</a>
[<a                                                                          
href="mailto:servletexec-interest-o
wner@newatlanta.com">mailto:servletexec-interest-o
wner@newatlanta.com</a>]
 <b><span style="font-weight: bold;">On Behalf Of         
</span></b><a
href="mailto:matt@newatlanta.com">matt@newatlanta.com</a><
br>
 <b><span style="font-weight:                                     
bold;">Sent:</span></b> Thursday, August
09, 2007
12:21 PM<br>
 <b><span style="font-weight:                                     
bold;">To:</span></b> <st1:PersonName
u4:st="on"><a                                                   
href="mailto:servletexec-interest@newatlanta.com">servletexec-i
nterest@newatlanta.com</a></st1:PersonName><br>
 <b><span style="font-weight:                                     
bold;">Subject:</span></b> Re:
[ServletExec]
Debugging AS with                                                               
Eclipse</span></font><o:p></o:p></p>
 </div>
 <u1:p></u1:p>
 <p class="MsoNormal"><font color="black"          
face="Times New Roman"
size="3"><span style="font-size:                           
12pt;"><u1:p>&nbsp;</u1:p><o:p></o:p></sp
an></font></p>
 <p class="MsoNormal"><font color="black"          
face="Verdana" size="3"><span
style="font-size: 12pt; font-family: Verdana;">Danny the correct   
way
to
step-debug your Servlets that run inside SE, using Eclipse IDE is to
run your
SE AS Instance inside Eclipse.<br>
For that you need to study the StartServletExec.bat file that's used to
startup
your instance.<br>
Use what you see there to configure Eclipse to start the instance.<br>
 <br>
This is typically done when the instance is running behind it's
built-in
webserver (not behind IIS).<br>
But I see no reason why you could not have the instance running behind
IIS.<br>
The only difference is that you'd be having Eclipse start the instance
rather
than using the batch file or the Windows Service mechanism to start             
it.<br>
 <br>
This FAQ may help:<br>
 <a
href="http://www.newatlanta.com/c/support/servletexec/self_help/faq/detail?
faqId=2">http://www.newatlanta.com/c/support/servletexec/self_help/faq/d
etail?faqId=2</a><br>
 <br>
Consider a simple HelloWorld java application.<br>
If you can set that up in Eclipse and step debug it, then you'd just
need to do
something similar to that to have Eclipse run your <st1:place
u4:st="on"><st1:place w:st="on">SE                 
AS</st1:place></st1:place> instance
in its debugger. Then you can
set breakpoints in your Servlet code, make a request, and step debug
your code.<br>
 <br>
 <br>
 </span></font><o:p></o:p></p>
 <u1:p></u1:p>
 <pre><font color="black" face="Courier New"       
size="2"><span
style="font-size: 10pt;">Matt                                      
McGinty<u1:p></u1:p><o:p></o:p></span></font>
;</pre>
 <pre><font color="black" face="Courier New"       
size="2"><span
style="font-size: 10pt;">Software                                  
Engineer<u1:p></u1:p><o:p></o:p></span></font&g
t;</pre>
 <pre><font color="black" face="Courier New"       
size="2"><span
style="font-size: 10pt;">New <st1:City                          
u4:st="on"><st1:place u4:st="on"><st1:City
w:st="on"><st1:place                                            
w:st="on">Atlanta</st1:place></st1:City></st1:place&
gt;</st1:City> Communications,                                            
LLC<u1:p></u1:p><o:p></o:p></span></font><
;/pre>
 <pre><font color="black" face="Courier New"       
size="2"><span
style="font-size: 10pt;"><a                                     
href="http://www.newatlanta.com">http://www.newatlanta.com</a>
;                                                                               
<u1:p></u1:p><o:p></o:p></span></font></p
re>
 <p class="MsoNormal"><font color="black"          
face="Times New Roman"
size="3"><span style="font-size: 12pt;"><br>

 <br>
Lin, Danny wrote:                                                               
<u1:p></u1:p><o:p></o:p></span></font></p
>
 <p class="MsoNormal"><font color="black"          
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial;">I have two AS         
instances
installed. The URLs are
cm.localhost and em.localhost. I am able to launch the application
(i.e. IIS
and ServletExec configured correctly.) I want to be able to run
step-through
debugger from Eclipse. I created a project and set it up for remote
Java Application.
I entered the following connection properties: host: cm.localhost,
port: 8888.
The port 8888 is the port when cm instance was installed. Is this a
correct way
to make debug connection? Or, is there another port that I should use?
After I
click &#8220;Debug&#8221; I am getting a Timeout                        
exception.<u5:p></u5:p></span></font><u1:p></u1
:p><o:p></o:p></p>
 <p class="MsoNormal"><font color="black"          
face="Arial" size="2"><span
style="font-size: 10pt; font-family:                                       
Arial;"><u5:p>&nbsp;</u5:p></span></font><
;u1:p></u1:p><o:p></o:p></p>
 <p class="MsoNormal"><font color="black"          
face="Arial" size="2"><span
style="font-size: 10pt; font-family: Arial;">Please                
help.<u5:p></u5:p></span></font><u1:p></u1:p>
;<o:p></o:p></p>
 <p class="MsoNormal"><font color="black"          
face="Arial" size="2"><span
style="font-size: 10pt; font-family:                                       
Arial;"><u5:p>&nbsp;</u5:p></span></font><
;u1:p></u1:p><o:p></o:p></p>
 <p class="MsoNormal"><font color="black"          
face="Arial" size="2"><span
style="font-size: 10pt; font-family:                                       
Arial;">Thanks.<u5:p></u5:p></span></font><u1
:p></u1:p><o:p></o:p></p>
 <p class="MsoNormal"><font color="black"          
face="Arial" size="2"><span
style="font-size: 10pt; font-family:                                       
Arial;">Danny<u5:p></u5:p></span></font><u1:p
></u1:p><o:p></o:p></p>
 <p class="MsoNormal"><font color="black"          
face="Arial" size="2"><span
style="font-size: 10pt; font-family:                                       
Arial;"><u5:p>&nbsp;</u5:p></span></font><
;u1:p></u1:p><o:p></o:p></p>
 </div>
</blockquote>
</body>
</html>

Message Thread
Date Subject Author
08/09/2007 Re: [ServletExec] Debugging AS with Eclipse matt@newatlanta.com
08/09/2007 RE: [ServletExec] Debugging AS with Eclipse danny.lin@verizonbusiness.com
08/09/2007 Re: [ServletExec] Debugging AS with Eclipse matt@newatlanta.com
08/09/2007 RE: [ServletExec] Debugging AS with Eclipse danny.lin@verizonbusiness.com
08/09/2007 Re: [ServletExec] Debugging AS with Eclipse matt@newatlanta.com
08/09/2007 [ServletExec] Debugging AS with Eclipse danny.lin@verizonbusiness.com
<< Back to Search Results


   
company media information terms of use privacy policy contact us