Application Server Solutions for Microsoft IIS and ASP.NET
       solutions   products   partners   company   support   downloads         store
ServletExec Self-Help: FAQ
Back to Search >  Back to Search Results

Faq ID 179
Product ServletExec
Category Installation, Web Server Support
Question I am unable to install SE AS 4.1.1 on Windows with Apache. Why ?
Answer The SE AS installer on Windows looks at registry entries in order to figure out which version of Apache is installed, where it resides, etc...

  • If using the Windows installer for SE 4.1.1 AS:
    If the installer is complaining that only Apache 1.3.9 - 1.3.23 is officially supported (when in fact up to Apache 1.3.26 is offically supported) then this is a bug in the SE 4.1.1 installer (which has been fixed in the SE 4.2b1 installer).
    It can be easily worked around in the following manner:
    1. Start - Run - regedit
    2. In the left pane of the Windows Registry Editor, browse to:
      HKEY_LOCAL_MACHINE\SOFTWARE\Apache Group\Apache
    3. Right click on that key and choose New - Key
    4. The name of the new key needs to be "1.3.23" (no quotes)
    5. In the left pane, left-click once on the new key that was just created to open it, showing its contents in the right pane.
    6. In the right-pane, right-click on nothing and choose New - String Value
    7. The name of the new string value should be "ServerRoot" (no quotes)
    8. Right-click on that string value and choose Modify.
    9. In the Value Data field type the absolute path to your Apache 1.3.26 installation. For example:
      C:\Program Files\Apache Group\Apache1.3.26\Apache
    Hint: you can examine the ServerRoot key of your:
    HKEY_LOCAL_MACHINE\SOFTWARE\Apache Group\Apache\1.3.26
    key and even copy its ServerRoot key value to your clipboard to ensure that you setup the 1.3.23 key to be the same as your 1.3.26 key.
    Then run the SE 4.1.1 installer.
    It should be tricked into thinking that a supported version of Apache is installed and proceed without errors.

    Note: You cannot do this with Apache 2.x.
    Apache 2.x has a completely different architecture than Apache 1.3.x. Apache 2.x on Windows is not supported by ServletExec 4.x in any manner. It is however possible to run SE 4.2 with Apache 2.x on Unix if you obtain and install the patched SE AS adapter for Apache 2 on Unix. See FAQ #195 for more information.

  • If using the Windows installer for SE 4.2 AS:
    The installer for SE 4.2 AS on windows is hard-coded to support as high as, Apache 1.3.27.
    But let's say you want to install it with Apache 1.3.28. Just do the registry trick described above, only create a dummy key for 1.3.27 instead of 1.3.23. It's the same concept... the installer is hard-coded up to the highest Apache version that was currently available at the time of its release.
    Note: You cannot do this with Apache 2.x.
    Apache 2.x has a completely different architecture than Apache 1.3.x. Apache 2.x on Windows is not supported by ServletExec 4.x in any manner. It is however possible to run SE 4.2 with Apache 2.x on Unix if you obtain and install the patched SE AS adapter for Apache 2 on Unix. See FAQ #195 for more information.
  • If using the Windows installer for SE 5.0 AS:
    When installing against an newer version of Apache 1.3.x or 2.x, the installer will display a warning but will still allow the install to continue. So with SE 5.0, it should install and work with newer versions of Apache as long as Apache is not modified in a way that breaks ServletExec.



   
company media information terms of use privacy policy contact us